Issue With Integrations Timing Out
Incident Report for Ardoq
Resolved
Users may have experienced issues with Integrations timing out between 2:00 PM - 3:30 PM CET. The issue has been resolved.
Posted Sep 03, 2024 - 12:00 UTC